+4M Downloads! Repair invalid LLM JSON, commonly used to parse the output of LLMs — Parsing ChatGPT and llm JSON stream response — Partial and incompl...
Pure Elm markdown parsing and rendering
A Go port of Rack's query string parser
:notebook_with_decorative_cover: Libraries.io Package Manager Manifest Parsers
PHP calculator library for mathematical terms (expressions) passed as strings
StarCraft - Brood War replay parser
Scrapbox notation → JavaScript Object
OCaml grammar for tree-sitter
Analyse PNG file format for CTF, python API and CLI
A c++17 recursive-descent generic PEG parsing library that supports left associative grammars, tokenization, multiple error handling etc..
Utility to parse and query HTML into an object shape
Library for serializing the Atom web content syndication format https://crates.io/crates/atom_syndication
A* CCG Parser with a Supertag and Dependency Factored Model
C++ library for parsing CAN databases (currently only with the DBC format)
Fast Indexed python HTML parser which builds a DOM node tree, providing common getElementsBy* functions for scraping, testing, modification, and forma...
Elixir binding for Libpostal - a library for parsing/normalizing street addresses around the world. Powered by statistical NLP and open geo data.
编程语言的本质:语言只是一串字符,我们认为它是什么,它就可以是什么
Semantic parser for API specifications
:waning_crescent_moon: formula ui generator
OpenSSH public key parser for Python
Fully parallel dynamically typed programming language
A little language interpreter written in Go
A lightweight C library for RDF syntax
Sample project with a basic Maven + JavaParser setup
mp4 file analyser written in Python
This site uses Lever's resume parsing API to parse resumes
Apache Anything To Triples (Any23) is a library, a web service and a command line tool that extracts structured data in RDF format from a variety of W...
Tokenizes a string that represents a regular expression.
:angel: Library to enable support for cascading stylesheets in AngleSharp.
AST parser and visitor for ClickHouse SQL
Lightweight syntax highlighter written in Qt
Blazing fast svelte-check (<1.0s) built with Rust
💧 Elixir NIF for cmark (C), a parser library following the CommonMark spec, a compatible implementation of Markdown.
一个简单的json解析器
A Java parser for ANSI ASC X12 documents.
Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643
Simple C Compiler in OCaml
F# grammar for treesitter
A teaching-oriented C-like compiler in Java, targeting JVM bytecode with parser, semantic analysis, backpatching, optimization, and end-to-end JVM tes...
Lightweight markup text formatting in Swift
Parses Paradox files into javascript objects
A parser combinator language and compiler designed to produce lossless syntax trees with robust, structured error recovery.
The INI header-only library for Modern C++ supports reading and writing, even writing comments. It is cross-platform and can be used on multiple opera...
A Flexible Rust Crate for DOM Querying and Manipulation
Generate a JSON documentation for a SFC Vue component. Contribute: https://gitlab.com/vuedoc/parser#contribute
ProLeap ANTLR4-based parser for Visual Basic 6.0
Crossplatform all-in-one INI-file parser, written on C++ with STL. Supports subsections, multiline values, arrays, maps and file inclusions.
PEG trace visualizer
Lightweight command-line framework for Go